18 July, 2013

You do not have permissions to connect to the server + Access Denied in SharePoint 2010

Problem Description:
Getting the following while launching SharePoint 2010 performance point dashboard designer and connecting to datasource.

Error Message:
Access Denied.  You do not have permissions to connect to the server.  Please contact your system administrator.

Entities used:
-SharePoint server 2010
-Performance point
-SQL Server 2008 R2
-BI template for the site collection
-IE7 + windows 7 OS

Troubleshooting done:
-Performance point service application is started or not
-performance point service is started or not
-secure store service application is started or not
-secure store service is started or not
-performance point service application is properly associated with the respective web application
-the account that we have used for configuring the performance point service application has proper rights in SQL or not
-what kind of rights user has on the specific site collection that is being used inside the dashboard designer

After checking all the steps and thorough analysis, we check the logs and found some traces with respect to the authentication.

We have checked the authentication part with respect to that web application and it was using claim based authentication.

As per the Microsoft theory regarding performance point services, it does not support any other authentication except windows authentication.

So conclusion is windows authentication is mandatory to make the performance point functional.

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

16 July, 2013

Unexpected error while creating a Business Intelligence Center site - SharePoint 2010

Hello Guys,

Today I am going to share one more interesting issue and troubleshooting steps so that it would be helpful to all of you.

Present environment entities:
-SharePoint server 2010
-SQL Server 2008 R2
-Windows 7 Operating system
-Internet Explorer 7

Problem description: We are trying to use the performance point in SharePoint so one of the basic need is to create a site with BI template i.e. business intelligence

-We opened our site collection
-site actions
-site settings
-site administration
-sites and workspaces
-provided site name, entered the appropriate URL, selected the required template i.e. business intelligence template and clicked OK
-as soon as we clicked OK then we got the following error message

Error Message:
An Unexpected error has occurred
Correlation ID
Date and time

Troubleshooting Done:
-Tried creating different site using different template under the same site collection- it works
-so one thing is sure that problem is with creating a BI template site.
-checked numerous site collection features
-activated performance point services at the site collection level
-checked the SharePoint logs and found the following:

Publishing Feature activation failed. Exception: System.InvalidOperationException: The SharePoint Server Publishing Infrastructure feature must be activated at the site collection level before the Publishing feature can be activated.    

From the above, it’s very clear that what needs to be done to make it working.

Activated Publishing infrastructure at the site collection level

-site actions
-site settings
-site collection administration
-site collection features
-activated Publishing infrastructure feature

Please let me know in case of any queries/questions so that we can discuss and proceed towards the resolution, Thank you.